No fix on gps even though tracking 8 satellites


#1

I am seeing up to 8 gps satellites but no fix? Does not appear to be receiving elevation or azimuth. Unit has clear view of sky and has been on for over20 minutes. Running latest software.


#2

What are you using for a GPS? I had the VK172 module and was experiencing horrible GPS performance. It would take 20-30 minutes to get a GPS fix and if I lost power for a brief time, it would try forever to get a fix. I read about the external GPS, so I added a USB pigtail and bought an external GPS. The external GPS fixed my issues and now I get a fix in 20-30 SECONDS rather than minutes. Furthermore, I put the VK172 on the USB pigtail (just on a whim) and, much to my surprise, the VK172 works just fine outside the FlightBox! Apparently the proximity of the VK172 to the SDRs or the Raspberry Pi itself caused the GPS issues.


#3

I have used the internal GPS and remote GPS provided by FlightBox. I had been flying the remote GPS and it was working well but noticed recently that the remote GPS could not acquire a fix. I took the box out of the aircraft and installed the original internal GPS and say the same behaviour. For some reason the internal GPS started working again, not sure what caused it to work again as I hadn’t changed anything in the setup. Note that I was running the system off of an external battery. Since I was able to get the GPS working again it does not appear to be a hardware problem (thought maybe the GPS antenna failed somehow). The only thing I can think of is that the power supply is not providing enough current? I saw some mention that the GPS antenna are sensitive to the voltage.