Experiencing AHRS Lite card problems


#1

Please provide the following information:

Hardware:
[ x] FlightBox Kit
[  ] FlightBox Assembled (FB1X)
[  ] Generic Stratux

FlightBox / Stratux version: (update-stratux-v1.3b2-FlightBox-v542a68fc26.sh)

FlightBox / Stratux build: (b827eb72cbaf)

Radio Configuration:
[x ] Dual Band
[  ] Single Band - US / CA - 978 MHz UAT
[  ] Single Band - International - 1090-ES

GPS Configuration:
[  ] None - Using mobile device's GPS
[x ] Open Flight Solutions Remote GPS
[  ] Internal GPS Module (VK-172)
[  ] Other:

USB Power Source:
[  ] USB Battery: (Make / Model Here)
[x ] Cigarette Lighter Adapter: (Make / Model Here)

USB Cable:
[x ] 3' heavy gauge cable included with FlightBox
[  ] Other: (Make / Model / Description Here)

EFB Application name and version:  FlyQ version 2.4.5

Please include a detailed description of your issue or question:

I have reported this to Support: Trouble ticket #47.

Has anyone run into problems with the AHRS Lite card? The fan isn’t working and the GPS is sporadic. I have hooked the fan up to a remote 5v power supply and it works. I have flashed the microUSB card back to v1.0r1 and then updated it to AHRS twice now. Without the card and original flash, all works fine. Updating with the card installed, consistently has the fan inoperable and the GPS turning on for 10 seconds to 3 mins, then turning off. With the board connected, there is 0 voltage across the fan contacts. Is it a flaw in the board? Any help would be appreciated.

The box currently is back to the original v1.0r1 w/o AHRS and working fine.

Thank you!

Andrew Whitten


#2

I can’t help on the fan, but an update to the GPS code broke the support for GPS connected over UART (that’s how the AHRS board GPS connects), so that’s a known issue. I don’t know if anyone is working on it. If you have an older GPS that connects via the USB port, you might just use that for the time being until the UART GPS issue is resolved.